Rackspace SMTP Sending Issues
Incident Report for HelpSpot
Resolved
Per Rackspace the SMTP issues are now resolved. The incident is now closed and mail delivery is operating as normal.
Posted Mar 26, 2019 - 11:21 EDT
Identified
Rackspace (Helpspot cloud's default email provider) is reporting some accounts are experiencing SMTP issues. You can find there status report here https://status.apps.rackspace.com/.
Posted Mar 26, 2019 - 10:14 EDT
This incident affected: HelpSpot Cloud: Email.