Rackspace's email is having an outage
Incident Report for HelpSpot
Resolved
Rackspace's engineering team was able to identify the underlying cause and make a configuration change to resolve this issue. Tests have returned positive results and connectivity has been restored to normal.
Posted May 09, 2016 - 17:23 EDT
Monitoring
HelpSpot Cloud customers using @helpspot.com email addresses may experience some errors sending or receiving emails until Rackspace (our service provider) resolves the issue. Details here: http://status.emailsrvr.com/
Posted May 09, 2016 - 16:44 EDT