Inbound email is offline
Incident Report for HelpSpot
Resolved
This incident has been resolved.
Posted Nov 21, 2023 - 15:13 EST
Update
Email importing should be returning to normal.

The outage was caused by a database error that occurred which then caused the email system to be in a state where concurrency locks were not cleared so HelpSpot thought emails were in mid-process of being imported when they were not.

We've cleared those locks and have identified a solution that will prevent this same error from occurring again in the future.

We're also working with AWS on our database which went through an AWS required update last week that has introduced extra load on the system. Changes made there look to have improved the initial instability but that work is ongoing.

If you see any further email system issues please reach out to support at customer.service@userscape.com
Posted Nov 21, 2023 - 09:55 EST
Investigating
Customer on US hosted HelpSpot installations are not pulling in email. We're currently investigating.
Posted Nov 21, 2023 - 08:09 EST
This incident affected: HelpSpot Cloud and HelpSpot Cloud: Email.